Complete
We have completed a full round of security improvements, infrastructure upgrades, and core feature work overnight. This includes grouped form sections, paginated submissions, a new submission detail view, a usage and billing page, and a cleaner onboarding experience. All services will be fully available to closed beta developers at 7:37 AM IST on March 14. We appreciate your patience through the maintenance window and are excited to get this in your hands.
In progress
Some services have been restored, however things are not fully stable yet. Our team is continuing to work through the remaining issues. We expect services to be fully available for closed beta by tomorrow morning at 7:37 AM IST. Thank you for bearing with us.
In progress
We are performing routine updates as we prepare for our public launch. During this time, beta testers may experience brief interruptions or downtime. We appreciate your patience while we work behind the scenes to improve the platform.