Resolved
This incident has been resolved.
Investigating
Our dashboard is currently unavailable due to an active outage on Vercel, which hosts our frontend. This is on Vercel's end and our team is monitoring the situation closely. A few pending updates that were scheduled for the closed beta release at 7:37 AM IST have also been held back as a result. We will push everything through as soon as Vercel recovers and will share an update once the dashboard is back up and the release is back on track.