Resolved
This incident has been resolved.
Monitoring
We've cleared the stuck database connections and restored access to form submissions. We've also implemented fixes to prevent this from happening again:
Changed the user activity update to a simple direct query (no transactions)
Added database timeouts to automatically kill stuck connections
Services are now fully operational. We're monitoring closely to ensure stability.
Identified
We've identified the issue — a few stuck database connections from our serverless functions. We're clearing them now to restore access to form submissions.
Investigating
We are currently experiencing an outage with our primary database. Form submissions are not loading in the dashboard and any functionality that depends on historical submission data is affected. New submissions may still be accepted but may not be visible until the database is fully restored. Our team is investigating and working to restore service as quickly as possible.