The checkout issue has been resolved. Users can now complete plan purchases and upgrades without any issues.
As part of this fix, we've updated our billing system to require a full name, phone number, and address from all users — this is a strict requirement from our payment processor. Existing users will receive an email shortly with instructions to update their details in the Account page.
We apologise for the disruption.
Resolved
The checkout issue has been resolved. Users can now complete plan purchases and upgrades without any issues.
As part of this fix, we've updated our billing system to require a full name, phone number, and address from all users — this is a strict requirement from our payment processor. Existing users will receive an email shortly with instructions to update their details in the Account page.
We apologise for the disruption.
Investigating
We are currently experiencing an issue with our checkout flow. Some users may be unable to complete plan purchases or upgrades. We are actively investigating and will post an update shortly. All other Aldform services remain fully operational.